Adobe Flash Player 8 or higher is required to play videos. If you do not have it, you can download it from the
Adobe Web site